Subscribe to updates
Powered by
Privacy policy
·
Terms of service
Partial downtime due to Cloudflare rate limiting
Resolved
·
Partial outage
All operation back to normal
Wed, Apr 29, 2026, 08:17 AM
(
11
hours ago)
·
View all updates
Affected components
08:04 AM
08:17 AM
Chat
App
Updates
Resolved
All operation back to normal
Wed, Apr 29, 2026, 08:17 AM
Identified
Partial outage across all services
Wed, Apr 29, 2026, 08:04 AM
(
13
minutes earlier)
Partial downtime due to Cloudflare rate limiting - Quickchat AI Status